Difference between revisions of "Dialogs:Preferences Dialog"

From TouchDesigner Documentation
Jump to: navigation, search
(Created page with "==<div class="sectionBarDialog">Description</div>== '''Preferences''' is a dialog for setting personal default settings for various TouchDesigner options. These preferences...")
 
Line 1: Line 1:
==<div class="sectionBarDialog">Description</div>==
+
==Description==
  
 
'''Preferences''' is  a dialog for setting personal default settings for various TouchDesigner options. These preferences are found in the ''Edit'' menu under ''Preferences...''. These options are saved so they apply to your next TouchDesigner session. These are split into several pages. The images below provide  a summary of the initial default preferences after installation.
 
'''Preferences''' is  a dialog for setting personal default settings for various TouchDesigner options. These preferences are found in the ''Edit'' menu under ''Preferences...''. These options are saved so they apply to your next TouchDesigner session. These are split into several pages. The images below provide  a summary of the initial default preferences after installation.
Line 7: Line 7:
 
'''Note:''' The preference file can be found here:
 
'''Note:''' The preference file can be found here:
  
Windows <code>C:/Users/''username''/AppData/Local/Derivative/TouchDesigner099</code>  
+
Windows <code>C:/Users/''username''/AppData/Local/Derivative/TouchDesigner099/pref.txt</code>  
  
macOS <code>~Library/Application Support/Derivative/TouchDesigner099</code>
+
macOS <code>~Library/Application Support/Derivative/TouchDesigner099</pref.txtcode>
  
==<div class="sectionBarDialog">General Preferences</div>==
+
==General Preferences==
  
<div align=center>[[image:PreferencesGeneral.png|300px]]</div>
+
[[image:PreferencesGeneral.png|300px]]
  
<span class="tipTextDialog">Increment Filename when Saving</span> -  When '''On''' name of your .toe file will have a number suffix increments every time you save the file. This does not happen with ''Save As'', only with ''Save''. When set to '''On and Copy to Backup Folder''' then the extra numbered .toe files will be placed in folder called Backup in the project's location on disk.
+
Increment Filename when Saving -  When '''On''' name of your .toe file will have a number suffix increments every time you save the file. This does not happen with ''Save As'', only with ''Save''. When set to '''On and Copy to Backup Folder''' then the extra numbered .toe files will be placed in folder called Backup in the project's location on disk.
  
<span class="tipTextDialog">Create Link Filename when Saving</span> - Creates a file that with no number increment that is the same as the most recent file saved. This makes it easy to open the most recent file.
+
Create Link Filename when Saving - Creates a file that with no number increment that is the same as the most recent file saved. This makes it easy to open the most recent file.
  
<span class="tipTextDialog">Prompt to Save on Exit</span> - If  <span class="tipTextDialog">'''Prompt to Save on Exit'''</span> is enabled, a pop-up dialog will appear whenever you attempt to close TouchDesigner. You will be prompted to either '''Save & Quit''', '''Discard & Quit''', or '''Cancel'''. The value of <span class="tipTextDialog">'''Increment Filename when Saving'''</span> will be honored when you select '''Save & Quit'''.  
+
Prompt to Save on Exit - If  '''Prompt to Save on Exit''' is enabled, a pop-up dialog will appear whenever you attempt to close TouchDesigner. You will be prompted to either '''Save & Quit''', '''Discard & Quit''', or '''Cancel'''. The value of '''Increment Filename when Saving''' will be honored when you select '''Save & Quit'''.  
  
<span class="tipTextDialog">Stop Playing when Minimized</span> - When enabled, animation will stop playing forward when the main TouchDesigner window is minimized. Once the window is reopened, playback will continue.  
+
Stop Playing when Minimized - When enabled, animation will stop playing forward when the main TouchDesigner window is minimized. Once the window is reopened, playback will continue.  
  
<span class="tipTextDialog">Maximum Size of Open Recent Menu</span> - Sets the maximum number of files (1-20) that will be displayed in the File > Open Recent menu.  
+
Maximum Size of Open Recent Menu - Sets the maximum number of files (1-20) that will be displayed in the File > Open Recent menu.  
  
<span class="tipTextDialog">Expose Expert Operators on Startup</span> - Makes additional expert level operators visible in the [[OP Create Dialog]].  
+
Expose Expert Operators on Startup - Makes additional expert level operators visible in the [[OP Create Dialog]].  
  
<span class="tipTextDialog">On/Off Parameter Behavior</span> - This sets how the On/Off toggles in parameter dialog function. Choose between clicking anywhere to toggle the state or specifically clicking on the left side for Off and right side for On.
+
On/Off Parameter Behavior - This sets how the On/Off toggles in parameter dialog function. Choose between clicking anywhere to toggle the state or specifically clicking on the left side for Off and right side for On.
  
<span class="tipTextDialog">Enable Warning Sounds</span> - An short sound will be played whenever a warning dialog is triggered.
+
Enable Warning Sounds - An short sound will be played whenever a warning dialog is triggered.
  
<span class="tipTextDialog">Enable [[Playbar]] Shortcuts</span> - Turn off to disable keyboard shortcuts for TouchDesigner's main [[Playbar]].
+
Enable [[Playbar]] Shortcuts - Turn off to disable keyboard shortcuts for TouchDesigner's main [[Playbar]].
  
<span class="tipTextDialog">Check for Experimental Builds</span> - Includes Experimental builds when checking for available updates.
+
Check for Experimental Builds - Includes Experimental builds when checking for available updates.
  
<span class="tipTextDialog">Offline Help Folder</span> - Path to the folder containing [[Offline Help]].
+
Offline Help Folder - Path to the folder containing [[Offline Help]].
  
<span class="tipTextDialog">Offline Help Date</span> - The date of the Offline Help located in the Offline Help Folder above.
+
Offline Help Date - The date of the Offline Help located in the Offline Help Folder above.
  
<span class="tipTextDialog">Always Use Offline Help</span> - Forces TouchDesigner to use Offline Help first, instead of checking the online help.
+
Always Use Offline Help - Forces TouchDesigner to use Offline Help first, instead of checking the online help.
  
<span class="tipTextDialog">Help Tags</span> - Enable or disable help pop-ups in the interface.
+
Help Tags - Enable or disable help pop-ups in the interface.
  
<span class="tipTextDialog">Default Node Language</span> - Determines whether new operators are created in Python Mode (default) or Tscript mode.
+
Default Node Language - Determines whether new operators are created in Python Mode (default) or Tscript mode.
  
<span class="tipTextDialog">Add External Python to Search Path</span> - When enabled touchDesigner will automatically add python33 installation folder into the module search path.
+
Add External Python to Search Path - When enabled TouchDesigner will automatically add python33 installation folder into the module search path.
  
<span class="tipTextDialog">Python 64-bit Module Path</span> - Additional search paths for python module search.
+
Python 64-bit Module Path - Additional search paths for python module search.
  
<span class="tipTextDialog">Use Startup File</span> - Allows for any .toe file to be loaded on startup.
+
Use Startup File - Allows for any .toe file to be loaded on startup.
  
<span class="tipTextDialog">Allow Scripts to run System Commands</span> - Allows TouchDesigner to run system commands.  This option is off by default.  This should be used with caution as system commands can perform operations that damage your Windows installation (ie. deleting files and directories)
+
Allow Scripts to run System Commands - Allows TouchDesigner to run system commands.  This option is off by default.  This should be used with caution as system commands can perform operations that damage your Windows installation (ie. deleting files and directories)
 
* Never - do not allow any system commands to run.
 
* Never - do not allow any system commands to run.
 
* Always - allow all system commands to run.
 
* Always - allow all system commands to run.
  
<span class="tipTextDialog">Hide Splash Screen</span> - When this is turned on, the splash screen will not show when TouchDesigner starts up.  This feature is only available in Commercial and Pro.
+
Hide Splash Screen - When this is turned on, the splash screen will not show when TouchDesigner starts up.  This feature is only available in Commercial and Pro.
  
<span class="tipTextDialog">Show Value Ladder Increment</span> -
+
Show Value Ladder Increment -
  
<span class="tipTextDialog">Value Ladder Step Size</span> -  
+
Value Ladder Step Size -  
  
<span class="tipTextDialog">Mouse Click Radius</span> - Number of pixels mouse clicks cover. Helpful for using stylus or other devices where double clicking on the same pixel is difficult or other accuracy issues arise.
+
Mouse Click Radius - Number of pixels mouse clicks cover. Helpful for using stylus or other devices where double clicking on the same pixel is difficult or other accuracy issues arise.
  
<span class="tipTextDialog">Show Startup Errors</span> - Show nothing, just warnings, or all errors on startup.
+
Show Startup Errors - Show nothing, just warnings, or all errors on startup.
  
==<div class="sectionBarDialog">Network Preferences</div>==
+
==Network Preferences==
  
<div align=center>[[image:PreferencesNetwork.png|300px]]</div>
+
[[image:PreferencesNetwork.png|300px]]
  
<span class="tipTextDialog">Center Zoom on Mouse</span> - Zooms the Layout Area in the Network Editor so that the point right beneath the mouse cursor is the center of the zoom.</span>
+
Center Zoom on Mouse - Zooms the Layout Area in the Network Editor so that the point right beneath the mouse cursor is the center of the zoom.
  
<span class="tipTextDialog">Resize TOP Nodes to TOP Viewer Aspect</span> - When selected, the size of TOP node will be locked so that the OP Viewer will not distort the underlying TOP.
+
Resize TOP Nodes to TOP Viewer Aspect - When selected, the size of TOP node will be locked so that the OP Viewer will not distort the underlying TOP.
  
<span class="tipTextDialog">Resize Panel COMP Nodes to Controlpanel Aspect</span> - When selected, the size of Panel node will be locked so that the OP Viewer will not distort the underlying Panel.
+
Resize Panel COMP Nodes to Controlpanel Aspect - When selected, the size of Panel node will be locked so that the OP Viewer will not distort the underlying Panel.
  
<span class="tipTextDialog">Mouse Wheel Navigation</span> - Allows users to move up and down the OP hierarchy by using the mouse wheel.
+
Mouse Wheel Navigation - Allows users to move up and down the OP hierarchy by using the mouse wheel.
  
<span class="tipTextDialog">Jump Up When Network Zoomed</span> - Sets the network zoom level which when reached will cause TouchDesigner to move up a level in the OP hierarchy.
+
Jump Up When Network Zoomed - Sets the network zoom level which when reached will cause TouchDesigner to move up a level in the OP hierarchy.
  
<span class="tipTextDialog">Scroll Wheel Zoom Boost</span> - A multiplier on the scroll wheel zooming feature. The higher the number, the quicker the network will zoom in and out on mouse wheel scrolls.
+
Scroll Wheel Zoom Boost - A multiplier on the scroll wheel zooming feature. The higher the number, the quicker the network will zoom in and out on mouse wheel scrolls.
  
<span class="tipTextDialog">Middle Mouse Button Zoom Boost</span> - A multiplier on the middle mouse button zooming. The higher the number, the quicker the network will zoom in and out using the middle mouse button.
+
Middle Mouse Button Zoom Boost - A multiplier on the middle mouse button zooming. The higher the number, the quicker the network will zoom in and out using the middle mouse button.
  
<span class="tipTextDialog">Translate/Zoom Delay (sec)</span> - Amount of lag in seconds added to translate or zoom operations on a network.  
+
Translate/Zoom Delay (sec) - Amount of lag in seconds added to translate or zoom operations on a network.  
  
<span class="tipTextDialog">Operator Name Max Size (pixels)</span> - Maximum height in pixels that operator names will appear in a network when zooming in.
+
Operator Name Max Size (pixels) - Maximum height in pixels that operator names will appear in a network when zooming in.
  
<span class="tipTextDialog">Fixed-size Operator Names</span> - If selected, operator names will not shrink and grow as the network is zoomed in and out, but instead will maintain a constant size through all network transformations.  
+
Fixed-size Operator Names - If selected, operator names will not shrink and grow as the network is zoomed in and out, but instead will maintain a constant size through all network transformations.  
  
<span class="tipTextDialog">Node Viewer On by Default</span> - Turn on the Node Viewers on all OPs by default.
+
Node Viewer On by Default - Turn on the Node Viewers on all OPs by default.
  
<span class="tipTextDialog">Turn on Node Viewers when Entering Network</span> - Turn on the Node Viewers on all OPs in a network when the network is first entered.
+
Turn on Node Viewers when Entering Network - Turn on the Node Viewers on all OPs in a network when the network is first entered.
  
<span class="tipTextDialog">Viewers Active On Click Select</span> - Turn on the Node Viewer of an OP when it is selected by clicking on the OP.
+
Viewers Active On Click Select - Turn on the Node Viewer of an OP when it is selected by clicking on the OP.
  
<span class="tipTextDialog">Cache Node Viewers</span> - Remember viewer layout for quicker navigation back and forth between networks.
+
Cache Node Viewers - Remember viewer layout for quicker navigation back and forth between networks.
  
<span class="tipTextDialog">Show Network Editor Grid</span> - Show grid on network background.
+
Show Network Editor Grid - Show grid on network background.
  
<span class="tipTextDialog">Grid Brightness</span> - If network grid is visible, adjust the brightness of the grid relative to the background.
+
Grid Brightness - If network grid is visible, adjust the brightness of the grid relative to the background.
  
<span class="tipTextDialog">Snap to Grid</span> - Sets the size of the grid to snap to for nodes. Can be set to '''Off''', '''Coarse''' or '''Fine'''.
+
Snap to Grid - Sets the size of the grid to snap to for nodes. Can be set to '''Off''', '''Coarse''' or '''Fine'''.
  
<span class="tipTextDialog">Snap to</span> - Sets the part of the node that will snap to the grid. Can be set to '''Lower Left Corner''' or '''Node Center'''.
+
Snap to - Sets the part of the node that will snap to the grid. Can be set to '''Lower Left Corner''' or '''Node Center'''.
  
==<div class="sectionBarDialog">Geometry Preferences</div>==
+
==Geometry Preferences==
  
<div align=center>[[image:PreferencesObjects.png|300px]]</div>
+
[[image:PreferencesObjects.png|300px]]
  
<span class="tipTextDialog">Keep Position when Parenting</span> - If unchecked, objects will assumed a position relative to the parent object when parented. Leaving the selection checked will allow objects to keep the world position.  
+
Keep Position when Parenting - If unchecked, objects will assumed a position relative to the parent object when parented. Leaving the selection checked will allow objects to keep the world position.  
  
<span class="tipTextDialog">Geometry Viewer BG Color</span> - Adjust the grayscale level of [[Geometry Viewer]]'s background color. This is reflected in all 3D viewers including Object Component viewers, SOP viewers, and MAT viewers.
+
Geometry Viewer BG Color - Adjust the grayscale level of [[Geometry Viewer]]'s background color. This is reflected in all 3D viewers including Object Component viewers, SOP viewers, and MAT viewers.
  
<span class="tipTextDialog">Adaptive Homing by Default</span> - All new 3D Viewers created will have Adaptive Homing turned on.
+
Adaptive Homing by Default - All new 3D Viewers created will have Adaptive Homing turned on.
  
<span class="tipTextDialog">Grid Visible by Default</span> - All new 3D Viewers created will have Grid turned on.
+
Grid Visible by Default - All new 3D Viewers created will have Grid turned on.
  
<span class="tipTextDialog">Set Viewers to Defaults</span> - Sets all viewer to the default set above.
+
Set Viewers to Defaults - Sets all viewer to the default set above.
  
==<div class="sectionBarDialog">TOPs Preferences</div>==
+
==TOPs Preferences==
  
<div align=center>[[image:PreferencesTOPs.png|300px]]</div>
+
[[image:PreferencesTOPs.png|300px]]
  
<span class="tipTextDialog">Viewer Background</span> - Change between a '''Checker Board''' or a '''Black''' background for TOPs.  
+
Viewer Background - Change between a '''Checker Board''' or a '''Black''' background for TOPs.  
  
<span class="tipTextDialog">Global Resolution Multiplier</span> - Multiplier for default resolution in all TOPs.
+
Global Resolution Multiplier - Multiplier for default resolution in all TOPs.
  
<span class="tipTextDialog">Power of Two Resize Bias</span> - Sets the bias for when to switch between different power of two resolutions for some older video cards.
+
Power of Two Resize Bias - Sets the bias for when to switch between different power of two resolutions for some older video cards.
  
<span class="tipTextDialog">Movie In CPU Cache Size (MB)</span> - Cache size to reserve on CPU for Movie File In TOPs. Refer to [[Movie File In TOP]] for details on proper use.
+
Movie In CPU Cache Size (MB) - Cache size to reserve on CPU for Movie File In TOPs. Refer to [[Movie File In TOP]] for details on proper use.
  
==<div class="sectionBarDialog">CHOPs Preferences</div>==
+
==CHOPs Preferences==
  
<div><center>[[image:PreferencesCHOPs.png|300px]]</center></div>
+
[[image:PreferencesCHOPs.png|300px]]
  
<span class="tipTextDialog">Maximum Time Slice Size (frames)</span> -  Sets an upper bound on the number of frames a time-sliced CHOP will process between successive screen updates. The default limits a time slice to be 6 frames).
+
Maximum Time Slice Size (frames) -  Sets an upper bound on the number of frames a time-sliced CHOP will process between successive screen updates. The default limits a time slice to be 6 frames).
  
<span class="tipTextDialog">Minimum Text Size</span> - The minimum text size used for [[Time Slice]]d CHOP viewers.
+
Minimum Text Size - The minimum text size used for [[Time Slice]]d CHOP viewers.
  
<span class="tipTextDialog">Maximum Text Size</span> - The maximum text size used for [[Time Slice]]d CHOP viewers.
+
Maximum Text Size - The maximum text size used for [[Time Slice]]d CHOP viewers.
  
<span class="tipTextDialog">Graph Color</span> - Sets the start color used when assigning colors to channels in CHOP graph viewers.
+
Graph Color - Sets the start color used when assigning colors to channels in CHOP graph viewers.
  
<span class="tipTextDialog">Hue Steps</span> - Sets the number of distinct hues assigned to the channels. After this number of colors is assigned, additional channels reuse the hues but apply the Value Multiplier below.
+
Hue Steps - Sets the number of distinct hues assigned to the channels. After this number of colors is assigned, additional channels reuse the hues but apply the Value Multiplier below.
  
<span class="tipTextDialog">Value Multiplier</span> - After the number of colors specified in Hue Steps are assigned, additional channels reuse the hues but apply this Value Multiplier.  This process is repeated as the Value Multiplier is reapplied each time the colors cycle through the number of Hue Steps.
+
Value Multiplier - After the number of colors specified in Hue Steps are assigned, additional channels reuse the hues but apply this Value Multiplier.  This process is repeated as the Value Multiplier is reapplied each time the colors cycle through the number of Hue Steps.
  
<span class="tipTextDialog">Value Minimum</span> - Sets a minimum value for the colors assigned.
+
Value Minimum - Sets a minimum value for the colors assigned.
  
<span class="tipTextDialog">Graph Style</span> - Sets the way colors are assigned to the channels.
+
Graph Style - Sets the way colors are assigned to the channels.
 
* Set Color by Channel Order - Uses the channel order to assign colors.
 
* Set Color by Channel Order - Uses the channel order to assign colors.
 
* Set Color by Channel Name - Uses the channel names to assign colors.
 
* Set Color by Channel Name - Uses the channel names to assign colors.
 
* Set Color by Path and Channel Name - Uses the path and channel names to assign colors.
 
* Set Color by Path and Channel Name - Uses the path and channel names to assign colors.
  
<span class="tipTextDialog">Graph Viewer</span> - Sets the display mode for graph viewers.
+
Graph Viewer - Sets the display mode for graph viewers.
 
* Single Graph for all Channels - This mode displays all channels in a CHOP in one graph.
 
* Single Graph for all Channels - This mode displays all channels in a CHOP in one graph.
 
* Single Graph per Channel - This mode displays each channel is its own graph.
 
* Single Graph per Channel - This mode displays each channel is its own graph.
  
==<div class="sectionBarDialog">DATs Preferences</div>==
+
==DATs Preferences==
  
<div align=center>[[image:PreferencesDATs.png|300px]]</div>
+
[[image:PreferencesDATs.png|300px]]
  
<span class="tipTextDialog">File Format</span> - Select the file format that the text will be stored in. Choose from '''Windows''' or '''Unix'''.   
+
File Format - Select the file format that the text will be stored in. Choose from '''Windows''' or '''Unix'''.   
  
<span class="tipTextDialog">Minimum Text Size</span> - Sets the minimum height in pixels for text when zooming out.
+
Minimum Text Size - Sets the minimum height in pixels for text when zooming out.
  
<span class="tipTextDialog">Maximum Text Size</span> - Sets the maximum height in pixels for text when zooming in.
+
Maximum Text Size - Sets the maximum height in pixels for text when zooming in.
  
<span class="tipTextDialog">Preferred Text Size</span> - Sets the preferred text size. Text will default to this size if not zoomed out or zoomed in too far.
+
Preferred Text Size - Sets the preferred text size. Text will default to this size if not zoomed out or zoomed in too far.
  
<span class="tipTextDialog">Auto Indent</span> - When enabled, pressing enter for new line will start the next line at the same level of indentation.
+
Auto Indent - When enabled, pressing enter for new line will start the next line at the same level of indentation.
  
<span class="tipTextDialog">Display Line Numbers</span> - Displays line numbers for DATs with text data.
+
Display Line Numbers - Displays line numbers for DATs with text data.
  
<span class="tipTextDialog">Display Row Numbers</span> - Displays row numbers for DATs with table data.
+
Display Row Numbers - Displays row numbers for DATs with table data.
  
<span class="tipTextDialog">Display Column Numbers</span> - Displays column numbers for DATs with table data.
+
Display Column Numbers - Displays column numbers for DATs with table data.
  
<span class="tipTextDialog">Text Editor</span> - Specify the external editor to use when editing text in DATs. Launch by RMB-clicking on DAT and selecting '''Edit Contents...'''
+
Text Editor - Specify the external editor to use when editing text in DATs. Launch by RMB-clicking on DAT and selecting '''Edit Contents...'''
  
<span class="tipTextDialog">Table Editor</span> - Specify the external editor to use when editing tables in DATs. Launch by RMB-clicking on DAT and selecting '''Edit Contents...'''
+
Table Editor - Specify the external editor to use when editing tables in DATs. Launch by RMB-clicking on DAT and selecting '''Edit Contents...'''
  
==<div class="sectionBarDialog">MATs Preferences</div>==
+
==MATs Preferences==
  
<div align=center>[[image:PreferencesMATs.png|300px]]</div>
+
[[image:PreferencesMATs.png|300px]]
  
 
'''NOTE:''' Using any of the MAT Preferences to speed up calculations of material normals and vectors, but be aware that doing so may cause artifacts to appear in your materials. Use local settings on MATs in the Optimize Parameter page to override these global values.
 
'''NOTE:''' Using any of the MAT Preferences to speed up calculations of material normals and vectors, but be aware that doing so may cause artifacts to appear in your materials. Use local settings on MATs in the Optimize Parameter page to override these global values.
  
<span class="tipTextDialog">Fast Normalize Half-Angle</span>
+
Fast Normalize Half-Angle
  
<span class="tipTextDialog">Don't Re-normalize Normal</span>
+
Don't Re-normalize Normal
  
<span class="tipTextDialog">Don't Re-normalize Light Vector</span>
+
Don't Re-normalize Light Vector
  
<span class="tipTextDialog">Don't Re-normalize Spot Vector</span>
+
Don't Re-normalize Spot Vector
  
<span class="tipTextDialog">Don't Re-normalize Eye Viewer</span>
+
Don't Re-normalize Eye Viewer
  
<span class="tipTextDialog">Fast Deform Tangent</span>
+
Fast Deform Tangent
  
 
[[Category:Dialogs and Menus]]
 
[[Category:Dialogs and Menus]]
 
[[Category:Settings]]
 
[[Category:Settings]]
 
[[Category:TDPages]]
 
[[Category:TDPages]]

Revision as of 11:11, 1 March 2018

Description[edit]

Preferences is a dialog for setting personal default settings for various TouchDesigner options. These preferences are found in the Edit menu under Preferences.... These options are saved so they apply to your next TouchDesigner session. These are split into several pages. The images below provide a summary of the initial default preferences after installation.

Note: The preference file can be found here:

Windows C:/Users/username/AppData/Local/Derivative/TouchDesigner099/pref.txt

macOS ~Library/Application Support/Derivative/TouchDesigner099</pref.txtcode>

General Preferences[edit]

PreferencesGeneral.png

Increment Filename when Saving - When On name of your .toe file will have a number suffix increments every time you save the file. This does not happen with Save As, only with Save. When set to On and Copy to Backup Folder then the extra numbered .toe files will be placed in folder called Backup in the project's location on disk.

Create Link Filename when Saving - Creates a file that with no number increment that is the same as the most recent file saved. This makes it easy to open the most recent file.

Prompt to Save on Exit - If Prompt to Save on Exit is enabled, a pop-up dialog will appear whenever you attempt to close TouchDesigner. You will be prompted to either Save & Quit, Discard & Quit, or Cancel. The value of Increment Filename when Saving will be honored when you select Save & Quit.

Stop Playing when Minimized - When enabled, animation will stop playing forward when the main TouchDesigner window is minimized. Once the window is reopened, playback will continue.

Maximum Size of Open Recent Menu - Sets the maximum number of files (1-20) that will be displayed in the File > Open Recent menu.

Expose Expert Operators on Startup - Makes additional expert level operators visible in the OP Create Dialog.

On/Off Parameter Behavior - This sets how the On/Off toggles in parameter dialog function. Choose between clicking anywhere to toggle the state or specifically clicking on the left side for Off and right side for On.

Enable Warning Sounds - An short sound will be played whenever a warning dialog is triggered.

Enable Playbar Shortcuts - Turn off to disable keyboard shortcuts for TouchDesigner's main Playbar.

Check for Experimental Builds - Includes Experimental builds when checking for available updates.

Offline Help Folder - Path to the folder containing Offline Help.

Offline Help Date - The date of the Offline Help located in the Offline Help Folder above.

Always Use Offline Help - Forces TouchDesigner to use Offline Help first, instead of checking the online help.

Help Tags - Enable or disable help pop-ups in the interface.

Default Node Language - Determines whether new operators are created in Python Mode (default) or Tscript mode.

Add External Python to Search Path - When enabled TouchDesigner will automatically add python33 installation folder into the module search path.

Python 64-bit Module Path - Additional search paths for python module search.

Use Startup File - Allows for any .toe file to be loaded on startup.

Allow Scripts to run System Commands - Allows TouchDesigner to run system commands. This option is off by default. This should be used with caution as system commands can perform operations that damage your Windows installation (ie. deleting files and directories)

  • Never - do not allow any system commands to run.
  • Always - allow all system commands to run.

Hide Splash Screen - When this is turned on, the splash screen will not show when TouchDesigner starts up. This feature is only available in Commercial and Pro.

Show Value Ladder Increment -

Value Ladder Step Size -

Mouse Click Radius - Number of pixels mouse clicks cover. Helpful for using stylus or other devices where double clicking on the same pixel is difficult or other accuracy issues arise.

Show Startup Errors - Show nothing, just warnings, or all errors on startup.

Network Preferences[edit]

PreferencesNetwork.png

Center Zoom on Mouse - Zooms the Layout Area in the Network Editor so that the point right beneath the mouse cursor is the center of the zoom.

Resize TOP Nodes to TOP Viewer Aspect - When selected, the size of TOP node will be locked so that the OP Viewer will not distort the underlying TOP.

Resize Panel COMP Nodes to Controlpanel Aspect - When selected, the size of Panel node will be locked so that the OP Viewer will not distort the underlying Panel.

Mouse Wheel Navigation - Allows users to move up and down the OP hierarchy by using the mouse wheel.

Jump Up When Network Zoomed - Sets the network zoom level which when reached will cause TouchDesigner to move up a level in the OP hierarchy.

Scroll Wheel Zoom Boost - A multiplier on the scroll wheel zooming feature. The higher the number, the quicker the network will zoom in and out on mouse wheel scrolls.

Middle Mouse Button Zoom Boost - A multiplier on the middle mouse button zooming. The higher the number, the quicker the network will zoom in and out using the middle mouse button.

Translate/Zoom Delay (sec) - Amount of lag in seconds added to translate or zoom operations on a network.

Operator Name Max Size (pixels) - Maximum height in pixels that operator names will appear in a network when zooming in.

Fixed-size Operator Names - If selected, operator names will not shrink and grow as the network is zoomed in and out, but instead will maintain a constant size through all network transformations.

Node Viewer On by Default - Turn on the Node Viewers on all OPs by default.

Turn on Node Viewers when Entering Network - Turn on the Node Viewers on all OPs in a network when the network is first entered.

Viewers Active On Click Select - Turn on the Node Viewer of an OP when it is selected by clicking on the OP.

Cache Node Viewers - Remember viewer layout for quicker navigation back and forth between networks.

Show Network Editor Grid - Show grid on network background.

Grid Brightness - If network grid is visible, adjust the brightness of the grid relative to the background.

Snap to Grid - Sets the size of the grid to snap to for nodes. Can be set to Off, Coarse or Fine.

Snap to - Sets the part of the node that will snap to the grid. Can be set to Lower Left Corner or Node Center.

Geometry Preferences[edit]

PreferencesObjects.png

Keep Position when Parenting - If unchecked, objects will assumed a position relative to the parent object when parented. Leaving the selection checked will allow objects to keep the world position.

Geometry Viewer BG Color - Adjust the grayscale level of Geometry Viewer's background color. This is reflected in all 3D viewers including Object Component viewers, SOP viewers, and MAT viewers.

Adaptive Homing by Default - All new 3D Viewers created will have Adaptive Homing turned on.

Grid Visible by Default - All new 3D Viewers created will have Grid turned on.

Set Viewers to Defaults - Sets all viewer to the default set above.

TOPs Preferences[edit]

PreferencesTOPs.png

Viewer Background - Change between a Checker Board or a Black background for TOPs.

Global Resolution Multiplier - Multiplier for default resolution in all TOPs.

Power of Two Resize Bias - Sets the bias for when to switch between different power of two resolutions for some older video cards.

Movie In CPU Cache Size (MB) - Cache size to reserve on CPU for Movie File In TOPs. Refer to Movie File In TOP for details on proper use.

CHOPs Preferences[edit]

PreferencesCHOPs.png

Maximum Time Slice Size (frames) - Sets an upper bound on the number of frames a time-sliced CHOP will process between successive screen updates. The default limits a time slice to be 6 frames).

Minimum Text Size - The minimum text size used for Time Sliced CHOP viewers.

Maximum Text Size - The maximum text size used for Time Sliced CHOP viewers.

Graph Color - Sets the start color used when assigning colors to channels in CHOP graph viewers.

Hue Steps - Sets the number of distinct hues assigned to the channels. After this number of colors is assigned, additional channels reuse the hues but apply the Value Multiplier below.

Value Multiplier - After the number of colors specified in Hue Steps are assigned, additional channels reuse the hues but apply this Value Multiplier. This process is repeated as the Value Multiplier is reapplied each time the colors cycle through the number of Hue Steps.

Value Minimum - Sets a minimum value for the colors assigned.

Graph Style - Sets the way colors are assigned to the channels.

  • Set Color by Channel Order - Uses the channel order to assign colors.
  • Set Color by Channel Name - Uses the channel names to assign colors.
  • Set Color by Path and Channel Name - Uses the path and channel names to assign colors.

Graph Viewer - Sets the display mode for graph viewers.

  • Single Graph for all Channels - This mode displays all channels in a CHOP in one graph.
  • Single Graph per Channel - This mode displays each channel is its own graph.

DATs Preferences[edit]

PreferencesDATs.png

File Format - Select the file format that the text will be stored in. Choose from Windows or Unix.

Minimum Text Size - Sets the minimum height in pixels for text when zooming out.

Maximum Text Size - Sets the maximum height in pixels for text when zooming in.

Preferred Text Size - Sets the preferred text size. Text will default to this size if not zoomed out or zoomed in too far.

Auto Indent - When enabled, pressing enter for new line will start the next line at the same level of indentation.

Display Line Numbers - Displays line numbers for DATs with text data.

Display Row Numbers - Displays row numbers for DATs with table data.

Display Column Numbers - Displays column numbers for DATs with table data.

Text Editor - Specify the external editor to use when editing text in DATs. Launch by RMB-clicking on DAT and selecting Edit Contents...

Table Editor - Specify the external editor to use when editing tables in DATs. Launch by RMB-clicking on DAT and selecting Edit Contents...

MATs Preferences[edit]

PreferencesMATs.png

NOTE: Using any of the MAT Preferences to speed up calculations of material normals and vectors, but be aware that doing so may cause artifacts to appear in your materials. Use local settings on MATs in the Optimize Parameter page to override these global values.

Fast Normalize Half-Angle

Don't Re-normalize Normal

Don't Re-normalize Light Vector

Don't Re-normalize Spot Vector

Don't Re-normalize Eye Viewer

Fast Deform Tangent

TOuch Environment file, the file type used by TouchDesigner to save your project.

The operating system's holder of files and other folders (directories). It does not refer to operators within TouchDesigner. See Network Path.

Unlike a Wire that connects nodes in the same Operator Family, a Link is the dashed lines between nodes that represent other data flowing between nodes, like CHOP Exports, node paths in parameters, and expressions in parameters referencing CHOP channels, DAT tables and other nodes.

The location of an operator within the TouchDesigner environment, for example, /geo1/torus1, a node called torus1 in a component called geo1. The path / is called Root. To refer instead to a filesystem folder, directory, disk file or http: address, see Folder.

TouchDesigner's original built-in Command scripting language prior to Python.

(1) The TouchDesigner window is made of a menu bar at the top, a Timeline at the bottom, plus one of a choice of Layouts in the middle. A Layout is made on one or more Panes, each Pane can contain a Network Editor, Viewer, Panel, etc. See Pane and Bookmark. (2) Nodes in a network are arranged using Layout commands in the RMB menu.

A pane type where networks of operators can be created and edited.

An Operator Family that creates, composites and modifies images, and reads/writes images and movies to/from files and the network. TOPs run on the graphics card's GPU.

An Operator Family that contains its own Network inside. There are twelve 3D Object Component and eight 2D Panel Component types. See also Network Path.

A custom interactive control panel built within TouchDesigner. Panels are created using Panel Components whose look is created entirely with TOPs.

The viewer found on each operator in a Network Editor pane. This viewer is turned on by clicking the Viewer Flag.

Any of the procedural data operators. OPs do all the work in TouchDesigner. They "cook" and output data to other OPs, which ultimately result in new images, data and audio being generated. See Node.

A 3D viewport for viewing and manipulating 3D scenes or objects interactively. A geometry viewer can be found in Panes (alt+3 in any pane) or the Node Viewers of all Geometry Object components.

The component types that are used to render 3D scenes: Geometry Component contain the 3D shapes to render, plus Camera, Light, Ambient Light, Null, Bone, Handle and other component types.

An Operator Family that contains its own Network inside. There are twelve 3D Object Component and eight 2D Panel Component types. See also Network Path.

An Operator Family that reads, creates and modifies 3D polygons, curves, NURBS surfaces, spheres, meatballs and other 3D surface data.

An Operator Family that associates a shader with a SOP or Geometry Object for rendering textured and lit objects.

In the node viewers of Geometry COMPs and SOPs, the Adaptive Homing option will continually keep in-view the 3D geometry being displayed, even when the geometry changes shape, size and animated position.

The width and height of an image in pixels. Most TOPs, like the Movie File In TOP can set the image resolution. See Aspect Ratio for the width/height ratio of an image, taking into account non-square pixels.

A Time Slice is the time from the last cook frame to the current cook frame. In CHOPs it is the set of short channels that only contain the CHOP channels' samples between the last and the current cook frame.

An Operator Family which operate on Channels (a series of numbers) which are used for animation, audio, mathematics, simulation, logic, UI construction, and many other applications.

An Operator Family that manipulates text strings: multi-line text or tables. Multi-line text is often a command Script, but can be any multi-line text. Tables are rows and columns of cells, each containing a text string.

The viewer of a node can be (1) the interior of a node (the Node Viewer), (2) a floating window (RMB->View... on node), or (3) a Pane that graphically shows the results of an operator.